加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

poj1503(大数相加)

发布时间:2020-12-14 04:08:30 所属栏目:大数据 来源:网络整理
导读:http://poj.org/problem?id=1503 Integer Inquiry Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 24392 Accepted: 9480 Description One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of po

http://poj.org/problem?id=1503

Integer Inquiry
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24392 Accepted: 9480

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

Source

East Central North America 1996
模拟大数相加。。
#include <stdio.h>
#include <string.h>
#define MAXN 1100
char s [MAXN +10 ];//数组开大点吧
int num [MAXN +10 ];
int main ()
{
memset (num , 0 , sizeof (num ));
memset (s , sizeof (s ));
int i ,j ;
while ( scanf ( "%s" ,s )!=EOF )
{
if ( strcmp (s , "0" )== 0 )
break ;
int len = strlen (s );
for (i = 0 ;i <len ;i ++)
{
num [i ]+=s [len -i -1 ]- '0' ;
//if(num[i]>9)
// {
// num[i]%=10;
// num[i+1]+=1;
// }
}
}
for (i = 0 ;i <MAXN ;i ++)
{
while (num [i ]>= 10 )
{
num [i +1 ]+=num [i ]/ 10 ;
num [i ]=num [i ]% 10 ;
}
}
for (i =MAXN ;i >= 0 ;i --) //去除前导0
{
if (num [i ]!= 0 )
break ;
}
for (j =i ;j >= 0 ;j --)
{
printf ( "%d" ,num [j ]);
}
printf ( " n " );
return 0 ;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读