加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1134 卡特兰数 大数乘法除法

发布时间:2020-12-14 04:06:38 所属栏目:大数据 来源:网络整理
导读:Problem Description This is a small but ancient game. You are supposed to write down the numbers 1,2,3,...,2n - 1,2n consecutively in clockwise order on the ground to form a circle,and then,to draw some straight line segments to connect th

Problem Description
This is a small but ancient game. You are supposed to write down the numbers 1,2,3,...,2n - 1,2n consecutively in clockwise order on the ground to form a circle,and then,to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. And,no two segments are allowed to intersect.

It's still a simple game,isn't it? But after you've written down the 2n numbers,can you tell me in how many different ways can you connect the numbers into pairs? Life is harder,right?
?

Input
Each line of the input file will be a single positive number n,except the last line,which is a number -1. You may assume that 1 <= n <= 100.
?

Output
For each n,print in a single line the number of ways to connect the 2n numbers into pairs.
?

Sample Input
  
  
2 3 -1
?

Sample Output
  
  
2 5
?



#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int n;
#define BASE 10000
#define UNIT 4
#define FORMAT "%04d"

class BigNum{
public:
	int a[20];
	int length;
	BigNum(const int k){ //用小于BASE的k初始化大数
		memset(a,sizeof(a));
		a[0] = k;
		length = 1;
	}
	BigNum(){
		memset(a,sizeof(a));
		length = 0;
	}
	BigNum operator * (const BigNum & B){
		BigNum ans;
		int i,j,up=0,num;
		for(i=0; i<length; i++){
			up = 0; //每次循环都要初始化为0
			for(j=0; j<B.length; j++){
				num = up + a[i] * B.a[j] + ans.a[i+j];
				up = num / BASE;
				num = num % BASE;
			//	cout << num << endl;
				ans.a[i+j] = num;
			}
		//	cout << up << endl;
			if(up > 0)
				ans.a[i+j] = up;
		}
		ans.length = i+j;
		while(ans.a[ans.length -1] == 0 && ans.length > 1)
			ans.length--;
		return ans;
	}
	BigNum operator /(const int & k) const{  // k < BASE,对此题适用
 		BigNum ans;
		int down=0,i,num;
		for(i=length-1; i>=0; i--){
			num = ( (down * BASE) + a[i] ) / k;
			down =  ( (down * BASE) + a[i] ) % k;
			ans.a[i] = num;
		}
		ans.length = length;
		while(ans.a[ans.length-1] == 0 && ans.length > 1)
			ans.length -- ;
		return ans;
	}
	void print(){
		printf("%d",a[length-1]);
		for(int i=length-2; i>=0; i--)
			printf(FORMAT,a[i]);
	}
};

//f(n) = C(2n,n)/(n+1)
int main(){
	BigNum nums[101];
	nums[1] = BigNum(1);
	nums[2] = BigNum(2);
	nums[3] = BigNum(5);
	for(int i=4; i<=100; i++){
		nums[i] = nums[i-1] * (4*i-2)/(i+1);
	}
	int n;
	while(scanf("%d",&n),n>0){
		nums[n].print();
		printf("n");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读