加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

大数加法 424 - Integer Inquiry

发布时间:2020-12-14 04:06:07 所属栏目:大数据 来源:网络整理
导读:UVa OJ Root?::?AOAPC I: Beginning Algorithm Contests (Rujia Liu)?::?Volume 1. Elementary Problem Solving?::?Big Number ?Integer Inquiry? One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powe

UVa OJ

Root?::?AOAPC I: Beginning Algorithm Contests (Rujia Liu)?::?Volume 1. Elementary Problem Solving?::?Big Number




?Integer Inquiry?

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670


就是最为基础的大数加法,通过一个reverse,将字符串反转之后比较容易处理

大数其实就是模拟,通过计算机模拟我们的手算

要注意输出时,将之前的0去掉


#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctype.h>
#include<algorithm>
using namespace std;
char num[150][150];
int sum[150]={0};
int main ()
{
    int t=0,i,j,max=0;
    memset(num,sizeof(num));
    memset(sum,sizeof(sum));
    while(gets(num[t]))
    {
        if (num[t][0]=='0') break;
        int len=strlen(num[t]);
        if (max<len) max=len;
        for (i=0,j=len-1; i<j; i++,j--)
        {
            char temp;
            temp=num[t][i];
            num[t][i]=num[t][j];
            num[t][j]=temp;
        }
        t++;
    }
    for (j=0; j<=max; j++)
    {
        for (i=0; i<t; i++)
            if (isdigit(num[i][j]))
            sum[j]+=num[i][j]-'0';
        if (sum[j]>=10)
        {
            sum[j+1]+=sum[j]/10;
            sum[j]=sum[j]%10;
        }
    }
    while(sum[j]==0)
        j--;
    for (i=j; i>=0; i--)
        cout<<sum[i];
    cout<<endl;
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读