加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu 1250 Hat's Fibonacci

发布时间:2020-12-14 04:04:11 所属栏目:大数据 来源:网络整理
导读:Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5590????Accepted Submission(s): 1866 Problem Description A Fibonacci sequence is calculated by adding the previous two

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5590????Accepted Submission(s): 1866


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
?

Input
Each line will contain an integers. Process to end of file.
?

Output
For each case,output the result in a line.
?

Sample Input
  
  
100
?

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
?

import java.math.BigInteger;
import java.util.Scanner;
public class Main{
	/*
	 * n<7040
	 */
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		//F f[]=new F[10000000];7040
		BigInteger f[]=new BigInteger[8];
		while(input.hasNext()){
			f[1]=BigInteger.valueOf(1);
			f[2]=BigInteger.valueOf(1);
			f[3]=BigInteger.valueOf(1);
			f[4]=BigInteger.valueOf(1);
			int n=input.nextInt();
			if(n<=4){
				System.out.println(f[n]);
			}
			else {
				for(int i=5;i<=n;i++)
				{
					f[5]=f[1].add(f[2].add(f[3].add(f[4])));
					f[1]=f[2];
					f[2]=f[3];
					f[3]=f[4];
					f[4]=f[5];
				}
				System.out.println(f[5].toString());
			}
		}
	}
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读