加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

How Many Fibs_hdu_1316(大数).java

发布时间:2020-12-14 04:02:21 所属栏目:大数据 来源:网络整理
导读:How Many Fibs? Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3098????Accepted Submission(s): 1232 Problem Description Recall the definition of the Fibonacci numbers:? f1 := 1? f2 :

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3098????Accepted Submission(s): 1232


Problem Description
Recall the definition of the Fibonacci numbers:?
f1 := 1?
f2 := 2?
fn := fn-1 + fn-2 (n >= 3)?

Given two numbers a and b,calculate how many Fibonacci numbers are in the range [a,b].?
?

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise,a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
?

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.?
?

Sample Input
  
  
10 100 1234567890 9876543210 0 0
?

Sample Output
  
  
5 4
?


import java.math.BigInteger;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		BigInteger f[]=new BigInteger[505];
		f[0]=BigInteger.valueOf(1);
		f[1]=BigInteger.valueOf(2);
		for(int i=2;i<502;i++){
			f[i]=f[i-1].add(f[i-2]);
		}
		while(true){
			BigInteger a=input.nextBigInteger();
			BigInteger b=input.nextBigInteger();
			if(a.equals(BigInteger.ZERO)&&b.equals(BigInteger.ZERO))
				break;
			int sum=0;
			for(int i=0;i<502&&b.compareTo(f[i])>=0;i++){
				if(f[i].compareTo(a)>=0)
					sum++;
			}
			System.out.println(sum);
		}
	}
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读