加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1131Count the Trees(卡特兰数 大数)

发布时间:2020-12-14 04:02:06 所属栏目:大数据 来源:网络整理
导读:Count the Trees Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1255????Accepted Submission(s): 818 Problem Description Another common social inability is known as ACM (Abnormally Co

Count the Trees

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1255????Accepted Submission(s): 818


Problem Description
Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging.?
Juan is a very gifted programmer,and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately,his loved ones are worried about him,because he has found a new exciting problem to exercise his intellectual powers,and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements.?

For example,given one element A,just one binary tree can be formed (using A as the root of the tree). With two elements,A and B,four different binary trees can be created,as shown in the figure.?


If you are able to provide a solution for this problem,Juan will be able to talk again,and his friends and family will be forever grateful.?

?

Input
The input will consist of several input cases,one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 100 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed.?
?

Output
For each input case print the number of binary trees that can be built using the n elements,followed by a newline character.?
?

Sample Input
  
  
1 2 10 25 0
?

Sample Output
  
  
1 4 60949324800 75414671852339208296275849248768000000
?

? ? ? ? ? ? ? ??
? ? ? ? ? ? ? ? ? ? ? 题目大意:推公式的题目,推出来是h(n)*n!卡特兰数经常在你觉得毫无规律的时候突然出现,比如那个数香蕉的题目。h(n)=h(n-1)*(4*n-2)/(n+1)

? ? ? ? ? ? ?解题思路:直接用大数处理。。。Counting Binary Trees

? ? ? ? ? ? ?题目地址:Count the Trees

AC代码:
import java.util.Scanner;
import java.util.Scanner.*;
import java.io.*;
import java.math.*;

public class Main //qixifestival 
{
     public static void main(String args[])
     {
    	 int p,i;
    	 Scanner cin = new Scanner(System.in);
    	 
    	 BigInteger res[],tmp1,tmp2,tmp3;
    	 res = new BigInteger[105];
    	 res[1]=BigInteger.ONE;
    	 tmp1=BigInteger.ONE;
    	 tmp2=BigInteger.ONE;
    	 for(i=2;i<=100;i++)
    	 {
    		 tmp3 = BigInteger.valueOf(i);
    		 //tmp2是n!
    		 tmp2=tmp2.multiply(tmp3);
    		 tmp3 = BigInteger.valueOf(4*i-2);
    		 tmp1=tmp1.multiply(tmp3);
    		 tmp3 = BigInteger.valueOf(i+1);
    		 //tmp1是h(n)
    		 tmp1=tmp1.divide(tmp3);
    		 res[i]=tmp1.multiply(tmp2);
    	 }
    	 while(cin.hasNext())
    	 {
    		 p=cin.nextInt();
    		 if(p==0)
    			 break;
    		 System.out.println(res[p]);
    	 }
     }
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读