加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu_1063,poj_1001_Exponentiation(大数,高精度) nyoj_155_求高

发布时间:2020-12-14 04:00:48 所属栏目:大数据 来源:网络整理
导读:Exponentiation Time Limit: 500MS ? Memory Limit: 10000K Total Submissions: 121666 ? Accepted: 29731 Description Problems involving the computation of exact values of very large magnitude and precision are common. For example,the computatio
Exponentiation
Time Limit: 500MS ? Memory Limit: 10000K
Total Submissions: 121666 ? Accepted: 29731

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example,the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6,and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input:
s is a string and n is an integer
C++

while(cin>>s>>n)

{

...

}

c

while(scanf("%s%d",s,&n)==2) //to  see if the scanf read in as many items as you want

/*while(scanf(%s%d",&n)!=EOF) //this also work    */

{

...

}

Source

East Central North America 1988


import java.math.BigDecimal;
import java.util.Scanner;

public class nyoj_155_求高精度幂 {
//Accepted 3360K 188MS Java 424B 2013-08-30 21:25:53 
	
	public static void main(String[] args) {
		
		Scanner sc =new Scanner(System.in);
		while(sc.hasNext()){
			BigDecimal a = sc.nextBigDecimal();
			int b =sc.nextInt();
			a=a.pow(b);
			String s=a.stripTrailingZeros().toPlainString();
			if(s.startsWith("0."))
				s=s.substring(1);
			System.out.println(s);			
		}
	}
}


说明:
1、stripTrailingZeros() ,返回类型为BigDecimal的小于此数的但除去尾部的0的数值。
2、toPlainString(),返回BigDecimal类型的String类型字符串。
3、startsWith(),确定此实例的开头是否与指定的字符串匹配。
4、substring(),返回一个新的字符串,它是此字符串的一个子字符串。该子字符串始于指定索引处的字符,一直到此字符串末尾。

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读