加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1316 How Many Fibs? 大数

发布时间:2020-12-14 03:55:01 所属栏目:大数据 来源:网络整理
导读:HDU 1316 题目链接 How Many Fibs? Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3281????Accepted Submission(s): 1312 Problem Description Recall the definition of the Fibonacci numbe



HDU 1316 题目链接

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3281????Accepted Submission(s): 1312


Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b,calculate how many Fibonacci numbers are in the range [a,b].
?

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise,a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
?

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
?

Sample Input
  
  
10 100 1234567890 9876543210 0 0
?

Sample Output
  
  
5 4
?

Source
University of Ulm Local Contest 2000
?

Recommend
Eddy???|???We have carefully selected several similar problems for you:?? 1753? 1063? 1047? 1147? 1102?


//---------------------------------------------------------------------------------------------------------------------------------------
//---------------------------------------------------------------------------------------------------------------------------------------


好吧,这道题目,让我WA了3次,实在是想哭,最后又重看了一遍题目,发现 f[1] = 1 ? f[2] = 2 ?, ?惯性思维害死人


思路也没什么特别的 ?大数相加,然后大数的比较

值得一提的还是审题啊


#include<iostream>
#include<stdio.h>
#include<string>
using namespace std;

struct ds{
	int num[105] ;
	int len ;
	void init( char s[105] = "0" ){
		memset( num,sizeof(num) );
		len = 0 ;
		int l = strlen(s) ;
		for( ; len < l ; ++len ){
			num[len] = s[l-1-len] - '0' ;
		}
		return ;
	}
	void plus( const ds& a,const ds& b ){
		this->init();
		int maxlen = a.len>b.len?a.len:b.len;
		for( len = 0 ; len < maxlen ; ++len )
			num[len] = a.num[len] + b.num[len] ;
		for( len = 0 ; len < maxlen ; ++len ){
			num[len+1] += num[len]/10 ;
			num[len] %= 10 ;
		}
		if( num[len] )
			++len ;
		return ;
	}
	bool is_less_than_or_equal_to( const ds& a ){
		if( len != a.len )
			return len<a.len ;
		for( int i = len - 1 ; i >= 0 ; --i ){
			if( num[i] != a.num[i] )
				return num[i]<a.num[i] ;
		}
		return true;
	}
}fb[500];

int main(){
	fb[1].init("1");
	fb[2].init("2");
	int i,ans ;
	for( i = 3 ; i < 500 ; ++i )
		fb[i].plus(fb[i-1],fb[i-2]);
	char a[105],b[105] ;
	ds aa,bb ;
	while( scanf( "%s%s",a,b ) ){
		if( strcmp(a,"0") == 0 && strcmp(b,"0") == 0 )
			break;
		aa.init(a);
		bb.init(b);
		ans = 0;
		for( i = 0 ; i < 500 ; ++i )
			if( aa.is_less_than_or_equal_to(fb[i]) && fb[i].is_less_than_or_equal_to(bb) )
				++ans;
		printf( "%dn",ans );
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读