加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Integer Inquiry(大数加法)

发布时间:2020-12-14 03:52:55 所属栏目:大数据 来源:网络整理
导读:Description ? Integer Inquiry ? One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. ``This supercomputer is

Description


?Integer Inquiry?

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670
 
 

解题报告

大数快恶心死我了。。。

借用白书里面关于忽略前导零的代码

for(j = 105; j >= 0; j--) if(a[j]) break; for(i = j; i >= 1; i--) printf("%d",a[i]);


#include <stdio.h>
#include <string.h>
char str[100];
int n[100];
int a[105];
int main()
{
    int i,l,f,c,s,j;
    memset(a,sizeof(a));
    while(scanf("%s",str))
    {
        if(str[0]=='0')
        break;
        l=strlen(str);
        memset(n,sizeof(n));
        for(i=0;i<l;i++)
            n[l-i]=str[i]-'0';
        for(i=1;i<=l;i++)
            a[i]+=n[i];
        for(i=1; i<105; i++)
        {
            a[i]+=(a[i-1]/10);
            a[i-1]%=10;
        }
    }
    for(j = 105; j >= 0; j--) if(a[j]) break;
    for(i = j; i >= 1; i--) printf("%d",a[i]);
    printf("n");
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读