加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

B - Dropping tests

发布时间:2020-12-14 03:51:01 所属栏目:大数据 来源:网络整理
导读:In a certain course,you take? n ?tests. If you get? a i ?out of? b i ?questions correct on test? i ,your cumulative average is defined to be . Given your test scores and a positive integer? k ,determine how high you can make your cumulativ

In a certain course,you take?n?tests. If you get?ai?out of?bi?questions correct on test?i,your cumulative average is defined to be

.

Given your test scores and a positive integer?k,determine how high you can make your cumulative average if you are allowed to drop any?k?of your test scores.

Suppose you take 3 tests with scores of 5/5,0/1,and 2/6. Without dropping any tests,your cumulative average is?

. However,if you drop the third test,your cumulative average becomes?

.

Input

The input test file will contain multiple test cases,each containing exactly three lines. The first line contains two integers,1 ≤?n?≤ 1000 and 0 ≤?k?<?n. The second line contains?n?integers indicating?ai?for all?i. The third line contains?npositive integers indicating?bi?for all?i. It is guaranteed that 0 ≤?ai?≤?bi?≤ 1,000,000. The end-of-file is marked by a test case with?n?=?k?= 0 and should not be processed.

Output

For each test case,write a single line with the highest cumulative average possible after dropping?k?of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors,the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e.,you can assume that the average is never 83.4997).

?

http://www.cnblogs.com/perseawe/archive/2012/05/03/01fsgh.html

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
#define eps 1e-7
int n,k;
double a[2005],b[2005],t[2005];

double gh(double x)
{
    for(int i=0;i<n;i++)
        t[i]=a[i]-x*b[i];
    sort(t,t+n);
    double ans=0;
    for(int i=k;i<n;i++)
        ans+=t[i];
    return ans;
}

int main()
{
    while(scanf("%d %d",&n,&k))
    {
        if(n==0&&k==0) break;
        for(int i=0;i<n;i++)
            scanf("%lf",&a[i]);
        for(int i=0;i<n;i++)
            scanf("%lf",&b[i]);
        double l=0.0,r=1.0,mid;
        while(r-l>eps)
        {
            mid=(l+r)/2;
            if(gh(mid)>0) l=mid;
            else r=mid;
        }
        printf("%1.fn",l*100);
    }
    return 0;
}
View Code

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读