加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

poj-2524 ubiquitous religions

发布时间:2020-12-14 03:49:28 所属栏目:大数据 来源:网络整理
导读:Time limit5000 ms Memory limit65536 kB There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university beli

Time limit5000 ms

Memory limit65536 kB

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.?

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore,many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data,you may not know what each person believes in,but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.?

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j,specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.?

Output

For each test case,print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input,scanf is recommended.
?
题意:几个数连起来,问你有几个块,就是问并查集里面有几个集合
?
题解:并查集的模版题,注意Hint中的用scanf就好了
?
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
using namespace std;
#define PI 3.14159265358979323846264338327950

int father[50003],n,m;

void init(int n)
{
    for(int i=0;i<n;i++)
    {
        father[i]=i;
    }
}

int find(int x)
{
    if(father[x]==x)
        return x;
    else
        return father[x]=find(father[x]);
}

void combine(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
        father[x]=y;
}

int main()
{
    int sum=0;
    while(scanf("%d %d",&m,&n) && (m||n))
    {
        init(m);
        int a,b,total=0;
        sum++;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&a,&b);
            combine(a,b);
        }
        for(int i=0;i<m;i++)
            if(father[i]==i)
                total++;
        printf("Case %d: %dn",sum,total);
                
    }
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读