加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

POJ 1089 Intervals【合并n个区间/贪心】

发布时间:2020-12-14 03:47:35 所属栏目:大数据 来源:网络整理
导读:There is given the series of n closed intervals [ai; bi],where i=1,2,...,n. The sum of those intervals may be represented as a sum of closed pairwise non?intersecting intervals. The task is to find such representation with the minimal numb
There is given the series of n closed intervals [ai; bi],where i=1,2,...,n. The sum of those intervals may be represented as a sum of closed pairwise non?intersecting intervals. The task is to find such representation with the minimal number of intervals. The intervals of this representation should be written in the output file in acceding order. We say that the intervals [a; b] and [c; d] are in ascending order if,and only if a <= b < c <= d.?
Task?
Write a program which:?
reads from the std input the description of the series of intervals,?
computes pairwise non?intersecting intervals satisfying the conditions given above,
writes the computed intervals in ascending order into std output

Input

In the first line of input there is one integer n,3 <= n <= 50000. This is the number of intervals. In the (i+1)?st line,1 <= i <= n,there is a description of the interval [ai; bi] in the form of two integers ai and bi separated by a single space,which are respectively the beginning and the end of the interval,1 <= ai <= bi <= 1000000.

Output

The output should contain descriptions of all computed pairwise non?intersecting intervals. In each line should be written a description of one interval. It should be composed of two integers,separated by a single space,the beginning and the end of the interval respectively. The intervals should be written into the output in ascending order.

Sample Input

5
5 6
1 4
10 10
6 9
8 10

Sample Output

1 4
5 10

?

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <string>
#include <cstring>
#include <vector>
#include <stack>
#include <queue>
#include <cmath>
#include <list>
#include <deque>
#include <map>
#include <set>
using namespace std;
#define ll long long
const double PI = acos(-1.0);
const int maxn = 101;
const int INF = 0x3f3f3f3f;
int dx[]={0,0,-1,1};
int dy[]={-1,1,0};

int n,m;
int f[maxn],cnt=0,sum=0;
struct node
{
    int l,r;
}a[maxn];
bool cmp(node a,node b)
{
    return a.l<b.l;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d %d",&a[i].l,&a[i].r);
        sort(a,a+n,cmp);
        int x=a[0].l,y=a[0].r;
        for(int i=0;i<n;i++)
        {
            if(a[i].l>=x && a[i].l<=y)
            {
                if(a[i].r>y)
                    y=a[i].r;
            }
            else
            {
                printf("%d %dn",x,y);
                x=a[i].l;
                y=a[i].r;
            }
        }
        printf("%d %dn",y);
    }
}
/*

*/

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读