加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu1002 A + B Problem II(大数相加)

发布时间:2020-12-14 03:42:29 所属栏目:大数据 来源:网络整理
导读:A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 189701????Accepted Submission(s): 36249 Problem Description I have a very simple problem for you. Given two integers

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 189701????Accepted Submission(s): 36249


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
?

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110
?
#include<stdio.h>
#include<string.h>
char s1[1004],s2[1004];
int a[1004],b[1004];
int main()
{
    int t,u,i,j,c;
    scanf("%d",&t);
    for(u=1;u<=t;u++)
    {
        memset(a,sizeof(a));
        memset(b,sizeof(b));
        scanf("%s%s",s1,s2);
        if(u!=1) printf("n");
        printf("Case %d:n%s + %s = ",s2);
        j=0;
        for(i=strlen(s1)-1;i>=0;i--)
            a[j++]=s1[i]-'0';
        j=0;
        for(i=strlen(s2)-1;i>=0;i--)
            b[j++]=s2[i]-'0';
        i=c=0;
        while(i<strlen(s1)||i<strlen(s2)||c)
        {
            a[i]+=b[i]+c;
            c=0;
            if(a[i]>9)
            {
                a[i]-=10;
                c=1;
            }
            i++;
        }
        for(--i;i>=0;i--)
            printf("%d",a[i]);
        printf("n");
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读