加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Big Number------HDOJ杭电1212(大数运算)

发布时间:2020-12-14 03:35:09 所属栏目:大数据 来源:网络整理
导读:Problem Description As we know,Big Number is always troublesome. But it's really important in our ACM. And today,your task is to write a program to calculate A mod B. To make the problem easier,I promise that B will be smaller than 100000.
Problem Description
As we know,Big Number is always troublesome. But it's really important in our ACM. And today,your task is to write a program to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.
?

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.
?

Output
For each test case,you have to ouput the result of A mod B.
?

Sample Input
  
  
2 3 12 7 152455856554521 3250
?

Sample Output
  
  
2 5 1521
?
题意简单,不用讲的呐!
要是你看不懂我很担心你的四级肿么办!!!!!!
直接上代码,可以作为模板!!!!!!
这代码有点抄袭别人的感觉;
开毛线玩笑,模板啊!!!!!!
模板不一样怎么叫模板!!!!!
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int main()
{
    int i,j,k;
    int t,n,m;
    char ch[1006];
    while(cin>>ch>>n)
    {
        m=0;
        for(i=0;i<strlen(ch);i++)
        {
            m*=10;
            m+=ch[i]-'0';
            m%=n;
        }
        printf("%dn",m);
    }
    return 0;
}
写代码能力有限,如有编程爱好者发现bug,还请指出,不胜感激!!!!!!

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读