加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

杭电 大数相加 A+B problem2

发布时间:2020-12-14 03:35:07 所属栏目:大数据 来源:网络整理
导读:Problem Description I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B. Input The first line of the input contains an integer T(1=T=20) which means the number of test cases. Then T li
Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110

?

大数相加的注意点是:保存大数的类型

代码:

#include<stdio.h>

#include<string.h>

int main()

{

??? int i=0,n=0,l=0,j=1;

??? char a[1000],b[1000];//注意大数相加里大数要用字符串表示

??? int num1[1000]={0},num2[1000]={0};

??? scanf("%d",&n);

??? while(n--)

??? {

??????? while(~scanf("%s%s",a,b))

??????? {

??????????? memset(num1,0,sizeof(num1));//数组清零

??????????? l=strlen(a)-1;

??????????? for(i=0;l>=0;l--,i++)

??????????? {

??????????????? num1[i]=a[l]-'0';//将输入的字符串中的数字变为普通//自然数

??????????? }

??????????? memset(num2,sizeof(num2)); //数组清零

??????????? l=strlen(b)-1;

? ??????????????num2[i]=b[l]-'0';

??????? //数字相加

??????????? for(i=0;i<1000;i++)

??????????????? num1[i]+=num2[i];

??????????????? num1[i+1]+=num1[i]/10;

??????????????? num1[i]%=10;

?????? //因为相加的时候是倒着加的为了输出原数字,倒着输出

??????????? int i=999;

??????????? while(!num1[i]) i--;

??????????? if(j!=1)printf("n");

??????????? printf("Case%d:n",j++);

??????????? printf("%s + %s =",b);

??????????? while(i>=0)

??????????????? printf("%d",num1[i--]);

??????????? printf("n");

??????? }???

??? }

??? return 0;

}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读