加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu1002 a+bII 大数相加

发布时间:2020-12-14 03:34:19 所属栏目:大数据 来源:网络整理
导读:表示无力吐槽!!又错了好几次 发表以明志!!! I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B. ? Input The first line of the input contains an integer T(1=T=20) which means the num

表示无力吐槽!!又错了好几次 发表以明志!!!

I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
?

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110
?
#include<stdio.h>
#include<string.h>
#define MAXN 1005
char a[MAXN],b[MAXN];
int c[MAXN];
int main()
{
	int t,i,j,k,v = 1;
	scanf( "%d",&t );
	while( t -- )
	{
		memset( c,sizeof(c) );
		scanf( "%s %s",a,b );
		int la = strlen(a),lb = strlen(b);
		i = la-1,j = lb-1;
		k = 0;
		while( i>=0&&j>=0 )
		{
			c[++k] += a[i--]-'0'+b[j--]-'0';
			if( c[k] > 9 )
			{
				c[k]-=10;
				++c[k+1];
			}
		}
		while(i>=0)
		{
			c[++k] += a[i--]-'0';
			if( c[k] > 9 )
			{
				c[k]-=10;
				++c[k+1];
			}
		}
		while(j>=0)
		{
			c[++k] += b[j--]-'0';
			if( c[k] > 9 )
			{
				c[k]-=10;
				++c[k+1];
			}
		}
		printf( "Case %d:n",v++ );
		printf( "%s + %s = ",b );
		for( i = MAXN; i > 0; i -- )
		if( c[i] ) break;
		for( ; i >0; i -- )
		printf( "%d",c[i] );
		printf( "n" );
		if(t!=0)
		printf( "n" );
	}
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读