加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

A + B Problem II HDU 1002 ——大数模拟

发布时间:2020-12-14 03:33:51 所属栏目:大数据 来源:网络整理
导读:Problem Description I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B. ? Input The first line of the input contains an integer T(1=T=20) which means the number of test cases. Then T

Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?

Sample Input
 
  
2 1 2 112233445566778899 998877665544332211
?

Sample Output
 
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110
?

这个是大数模拟:


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

using namespace std;

char s1[1010];
char s2[1010];//定义s1,s2为第一个数和第二个数
int ls[1020];//保存和的数组

int main()
{
    int n,l1,l2,i,j,k,c=0,x,y,a,b;
    scanf("%d",&n);
    while(n--)
    {
        c++;
        memset(s1,'',sizeof(s1));
        memset(s2,sizeof(s2));
        memset(ls,sizeof(ls));//这个必须有,否则的话会影响结果
        scanf("%s",s1);
        scanf("%s",s2);
        l1=strlen(s1);
        l2=strlen(s2);
        y=0;
        for(i=l1-1,j=l2-1;i>=0||j>=0;i--,j--)//i和j同时访问s1,s2;
        {
            if(i>=0)//因为s1和s2长度可能不一样,如果哪个数组先用完了
                //后面的就用0来补
            {
                a=s1[i]-'0';
            }
            else
            {
                a=0;
            }
            if(j>=0)//对于第二个数组同样这样处理
            {
                b=s2[j]-'0';
            }
            else
            {
                b=0;
            }
            ls[y++]=a+b;
        }
        for(i=0;i<y;i++)
        {
            ls[i+1]+=(ls[i]/10);
            ls[i]%=10;//对进位进行处理
        }
        printf("Case %d:n",c);
        printf("%s + %s = ",s1,s2);
        i=y;
        while(ls[i]==0)
        {
            i--;//去掉前导0
        }
        for(;i>=0;i--)
        {
            printf("%d",ls[i]);
        }
        printf("n");
        if(n!=0)
            printf("n");
    }
    return 0;
}
一开始没注意那个长度,结果错了好几回,总的来说,大数模拟就是模拟用手算加法...

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读