加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

POJ 2506 Tiling 递推+大数

发布时间:2020-12-14 03:30:34 所属栏目:大数据 来源:网络整理
导读:n how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? Here is a sample tiling of a 2x17 rectangle. Input Input is a sequence of lines,each line containing an integer number 0 = n = 250. Output For each line of input,output one
n how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.


Input

Input is a sequence of lines,each line containing an integer number 0 <= n <= 250.

Output

For each line of input,output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251


题意 :有一个2*n的大长方体;只用1*2,2*2两种长方体有多少种方法构成这个大长方体

代码:

import java.math.BigInteger;
import java.util.Scanner;;
public class Main {
	public static void main(String[] args) 
	{
		Scanner cin=new Scanner(System.in);
		BigInteger[] q=new BigInteger[255];             //大数数组的 定义
		q[0]=BigInteger.ONE;                            //大数数组的元素赋值 q[0]=1
		q[1]=BigInteger.ONE;                            
		q[2]=q[0].add(q[0].add(q[1]));                  //大数的加减乘除都是函数形式
		for(int i=3;i<=250;i++)
			q[i]=q[i-1].add(q[i-2].add(q[i-2]));
		int t;
		while(cin.hasNext())                    //多重输入
		{
			t=cin.nextInt();
			System.out.println(q[t]);
		}
		cin.close();                //多重输入要关闭文件
	}
}

简单的递推题 但加上了大数。。??

再次证明了JAVA对大数问题的简单实用

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读