加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1042 N! 阶乘(大数)

发布时间:2020-12-14 03:29:30 所属栏目:大数据 来源:网络整理
导读:Problem Description Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N! ? Input One N in one line,process to the end of file. ? Output For each N,output N! in one line. ? Sample Input 123 ? Sample Output 12 6 代码: pre name="
Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
?

Input
One N in one line,process to the end of file.
?

Output
For each N,output N! in one line.
?

Sample Input
  
  
1 2 3
?

Sample Output
  
  
1 2

6

代码:

<pre name="code" class="java">import java.util.Scanner;
import java.math.BigInteger;  
public class Main {
	public static void main(String[] args) {
		Scanner cin= new Scanner(System.in);  //加快啥的
          int i;    
          int t;
          while(cin.hasNext()) //多重输入
          {
        	  t=cin.nextInt();    	
        	   BigInteger res=BigInteger.ONE;  
          for(i=2;i<=t;i++)
          {
        	  res=res.multiply(BigInteger.valueOf((long)i));     //将i的类型改为long 
          }
        	  System.out.println(res);
          }
	}
}
又一次证明JAVA的重要性 瞬间变水题啊 有木有。。

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读