加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ 题目1042 N!(大数)

发布时间:2020-12-14 03:27:52 所属栏目:大数据 来源:网络整理
导读:N! Time Limit: 10000/5000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 53495????Accepted Submission(s): 15120 Problem Description Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N! ? Inpu

N!

Time Limit: 10000/5000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53495????Accepted Submission(s): 15120


Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
?

Input
One N in one line,process to the end of file.
?

Output
For each N,output N! in one line.
?

Sample Input
  
  
1 2 3
?

Sample Output
  
  
1 2 6
?

Author
JGShining(极光炫影)
题目大意:计算大数的阶乘
要点:数组开大些,,,,,又开小了,wa了一次
ac代码
#include<stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,a[100200],c,d=1,tc,j;
		a[1]=1;
		for(i=1;i<=n;i++)
		{
			for(j=1,c=0;j<=d;j++)
			{
				tc=a[j]*i+c;
				a[j]=tc%10;
				c=tc/10;
			}
			while(c)
			{
				a[++d]=c%10;
				c/=10;
			}
		}
		for(i=d;i>=1;i--)
			printf("%d",a[i]);
		printf("n");
	}
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读