加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

UVA 10106 Product (大数相乘)

发布时间:2020-12-14 03:27:51 所属栏目:大数据 来源:网络整理
导读:Product ? The Problem The problem is to multiply two integers X,Y. ( 0=X,Y10 250 ) The Input The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer. The Output For each input pair of lines the output l

Product?

The Problem

The problem is to multiply two integers X,Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444


大数相乘,网上有很多模板,今下午练练手,自己写一遍,刚开始忽略了前置0,导致0*12=00,0*123=000,后来改了输出就ac了。

#include <iostream>
#include <cstring>
#define maxn 260
using namespace std;
int main()
{
    char str1[maxn],str2[maxn];
    while(cin>>str1>>str2)
	{		
		int len1,len2;
		len1=strlen(str1);
		len2=strlen(str2);
		
		int s1[maxn],s2[maxn];
		memset(s1,sizeof(s1));
		memset(s2,sizeof(s2));
		
		int i;
		for(i=0;i<len1;i++)
			s1[i]=str1[i]-'0';
		for(i=0;i<len2;i++)
			s2[i]=str2[i]-'0';
		
		int sum[maxn+maxn];
		memset(sum,sizeof(sum));
		int j,k;
		for(i=len2-1;i>=0;i--)
		{
			for(j=len1-1;j>=0;j--)
			{
				sum[i+j+1]=sum[i+j+1]+s2[i]*s1[j];
			}
		}
		for(k=len1+len2-1;k>=0;k--)
			if(sum[k]>=10)
			{
				int temp;
				temp=sum[k]%10;
				sum[k-1]=sum[k-1]+sum[k]/10;
				sum[k]=temp;
			}
			
			//if(sum[0]!=0)
			//	cout<<sum[0];
			bool flag=0;
			for(i=0;i<len1+len2-1;i++)
			{
				if(sum[i]!=0)
					flag=1;
				if(flag==1)
				cout<<sum[i];
			}
			cout<<sum[len1+len2-1];
			cout<<endl;
	}
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读