加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Bi-shoe and Phi-shoe 线筛欧拉函数

发布时间:2020-12-14 03:14:29 所属栏目:大数据 来源:网络整理
导读:Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students,so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of B

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students,so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information,Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So,score of a bamboo of length 9 is 6 as 1,2,4,5,7,8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist,each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T (≤ 100),denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1,106].

Output
For each case,print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha

首先最重要的 要读懂这题让干嘛 = =
就是给一串数 这些数是某个欧拉函数的值 找到最小自变量并求和
即phi(n) = x; x已知 求满足phi(n) = x 的n的最小值 并对所有xi求和

#include <cstdio>
#include <algorithm>
using namespace std;
#define ll long long
const int N = 1000000+5;
int phi[N];
int num[10005];
// 线筛欧拉函数
void euler(){
    phi[1] = 1;
    for (int i = 2; i < N; ++i){
        if (!phi[i]){
            for (int j = i; j < N; j += i){
                if (!phi[j]) phi[j] = j;
                phi[j] = phi[j]/i*(i-1);
            }
        }
    }
}
int main(){
    euler();
    int t;
    int kase = 1;
    scanf("%d",&t);
    while (t--){
        int n;
        scanf("%d",&n);
        for (int i = 0; i < n; ++i){
            scanf("%d",&num[i]);
        }
        sort(num,num+n);
        ll sum = 0; //注意是 long long 10^6*10000
        for (int i = 0,j = 2;i < n;){
            if (phi[j] >= num[i]){
                sum+=j;
                i++;
            }else j++;
        }
        printf("Case %d: %lld Xukhan",kase++,sum);
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读