加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

大数据之大数相加

发布时间:2020-12-14 03:09:40 所属栏目:大数据 来源:网络整理
导读:描述 I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B. A,B must be positive. 输入 The first line of the input contains an integer T(1=T=20) which means the number of test cases. The

描述
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
A,B must be positive.
输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case,you should output two lines. The first line is “Case #:”,# means the number of the test case. The second line is the an equation “A + B = Sum”,Sum means the result of A + B. Note there are some spaces int the equation.

样例输入

2
1 2

112233445566778899 998877665544332211

样例输出

Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110

代码如下:

package dashuju;

import java.util.Scanner;

public class dashuxiangjia {

  public static void main(String[] args) {
    Scanner sc = new Scanner(System.in);
    int  i = sc.nextInt();
    for (int j=1; j<=i;j++){
    String a,b;
    a = sc.next();
    b = sc.next();
    int changdu = a.length() - b.length() > 0 ? a.length() : b.length();    
    int[] aint = new int[changdu];
    int[] bint = new int[changdu];
    for (int i1 = 0; i1 < a.length(); i1++) {
      aint[a.length()-1-i1] = Integer.parseInt(a.substring(i1,i1 + 1));
    }
    for (int i1 = 0; i1 < b.length(); i1++) {
      bint[b.length()-1-i1] = Integer.parseInt(b.substring(i1,i1 + 1));
    }
    int[] sum = new int[changdu + 1];
    for (int i3 = 0; i3 < changdu; i3++) {
      sum[i3] = aint[i3] + bint[i3];
    }
    for (int i4 = 0; i4 < changdu; i4++) {
      sum[i4 + 1] = sum[i4] / 10 + sum[i4 + 1];
      sum[i4] = sum[i4] % 10;
    }
    int sumchangdu = changdu;
    while (sum[sumchangdu] == 0) {
      sumchangdu--;
    }
    System.out.println("Case "+j+":");
    System.out.print(a + " + " + b + " = ");
    for (int i5 = sumchangdu; i5 >= 0; i5--) {
      System.out.print(sum[i5]);
    }
  }
  }
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读