加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

大数问题之 Integer Inquiry hdoj 1047

发布时间:2020-12-14 03:07:14 所属栏目:大数据 来源:网络整理
导读:Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)??? Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12499??? Accepted Submission(s): 3153 Problem Description One of the first users of BIT's new supercomputer was Chip D

Integer Inquiry
Time Limit: 2000/1000 MS (Java/Others)??? Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12499??? Accepted Submission(s): 3153


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)

?

Input
The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

?

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

?

Sample Input
1


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
?

Sample Output
370370367037037036703703703670
?

Source
East Central North America 1996

/*

题意:

将给出的大数相加起来,看数据即懂

*/

/*
100个100位的数相加,和不会超过102位的。如100个最大两位数99相加,也不过9900,四位数搞定。因此102个数组元素足够

为了减小内存使用动态数组;
*/

#include<cstdio>
#include<string.h>
#include<malloc.h>
#include<stdlib.h>
#define M 102
void add(char *a,int *sum)
{
?int i,j,l,alen;
?alen=strlen(a);
?
?int *num=(int*)malloc(sizeof(int)*alen);
?for(i=0;i<alen;i++)
?? num[i]=0;
??
?for(i=alen-1,j=0;i>=0;i--,j++)
????? num[j]=a[i]-'0';
?for(i=0;i<alen;i++)
? {
? ?sum[i]+=num[i];
? ?? if(sum[i]>9)
? ? {
? ?? sum[i]-=10;
???? sum[i+1]+=1;?
? ? }
? }
? free(num);???
}

int main() { ?int ca; ?scanf("%d",&ca); ?while(ca--) ?{ ?? int i=0; ?? char *a=(char*)malloc(sizeof(char)*M); ?? int? *sum=(int*)malloc(sizeof(int)*M); ?? for(i=0;i<M;i++) ????? sum[i]=0; ????? ?? while(scanf("%s",a)&&a[0]!='0') ???add(a,sum); ??? ???? ??for(i=M-1;i>=0&&sum[i]==0;i--) ?? ???????? ; ???????? if(i>=0) ???? for(;i>=0;i--) ????? printf("%d",sum[i]); ????? else ?????? printf("0"); ??? printf("n");? ???? ?if(ca!=0) ???? printf("n");? ???? free(a); ???? free(sum); ? ?} ?return 0; }

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读