加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

ZOJ 3167(大数乘小数的简单应用)

发布时间:2020-12-14 03:05:14 所属栏目:大数据 来源:网络整理
导读:题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3199 Find 7 Faster Than John Von Neumann Time Limit: 1 Second Memory Limit: 32768 KB It was said that when testing the first computer designed by von Neumann,people gave

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3199

Find 7 Faster Than John Von Neumann

Time Limit: 1 Second Memory Limit: 32768 KB

It was said that when testing the first computer designed by von Neumann,people gave the following problem to both the legendary professor and the new computer: If the 4th digit of 2^n is 7,what is the smallest n? The machine and von Neumann began computing at the same moment,and von Neumann gave the answer first.

Now you are challenged with a similar but more complicated problem: If the K-th digit of M^n is 7,what is the smallest n?

Input

Each case is given in a line with 2 numbers: K and M (< 1,000).

Output

For each test case,please output in a line the smallest n.

You can assume:

  1. The answer always exist.
  2. The answer is no more than 100.

Sample Input

3 2
4 2
4 3

Sample Output

15
21
11
AC代码:

#include <stdio.h>
#include <string.h>
int a[300],b[300];
void mul(int i){
    int j,k;
    for(j=0;j<300;j++)
        b[j]*=i;
    for(i=k=0;i<300;i++){
        j=(b[i]+k)/10;
        b[i]=(b[i]+k)%10;
        k=j;
    }
}
int main(){
    int n,k,m,i,p;
    while(~scanf("%d%d",&k,&m)){
        memset(a,sizeof(a));
        memset(b,sizeof(b));
        p=m;
        n=1;
        for(i=0;p;i++){
            a[i]=b[i]=p%10;
            p/=10;
        }
        while(a[k-1]-7){
			mul(m);
            for(i=0;i<300;i++)
                a[i]=b[i];
            n++;
        }
        printf("%dn",n);
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读