加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu-1042-N!(大数)

发布时间:2020-12-14 03:04:10 所属栏目:大数据 来源:网络整理
导读:N! Time Limit: 10000/5000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 54232????Accepted Submission(s): 15394 Problem Description Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N! ? Inpu

N!

Time Limit: 10000/5000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54232????Accepted Submission(s): 15394


Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
?

Input
One N in one line,process to the end of file.
?

Output
For each N,output N! in one line.
?

Sample Input
  
  
1 2 3
?

Sample Output
  
  
1 2 6
代码:
#include<stdio.h>
#include<string.h>
#define MAX 50000//数组要开合适,开到10000会wrong!!!! 开到1000000会超时!!!!!
int a[MAX];
int main()
{
   int n;
   while(~scanf("%d",&n))
   {
        memset(a,sizeof(a));
        a[0]=1;
        int i,j,d,c=0;
        for(i=2;i<=n;++i)
        {   c=0;
            for(j=0;j<MAX;++j)
            {
                d=a[j]*i+c;
                a[j]=d%10;
                c=d/10;
            }
        }
        while(c)
        {
            a[j++]=c%10;
            c=c/10;
        }
        for(j=MAX-1;j>0;--j)
        if(a[j]!=0)
        break;
        for(;j>=0;--j)
        printf("%d",a[j]);
        printf("n");
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读