加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

大数相加

发布时间:2020-12-14 03:03:09 所属栏目:大数据 来源:网络整理
导读:原题http://acm.hdu.edu.cn/showproblem.php?pid=1047 Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)??? Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12692??? Accepted Submission(s): 3214 Problem Description One of th

原题http://acm.hdu.edu.cn/showproblem.php?pid=1047

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)??? Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12692??? Accepted Submission(s): 3214


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)


?

Input
The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.


?

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


?

Sample Input
  
  
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0


?

Sample Output
  
  
370370367037037036703703703670
#include <stdio.h>
#include <stdlib.h>
#include <limits.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <iostream>
#include <queue>
#include <deque>
#include <stack>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define MAXN 500 + 10
char a[MAXN],b[MAXN],c[MAXN],sum[MAXN];
//int count;
int mark;

void jia(char sum[],char a[]){
    int i,j,z,k,count;
    k = 0;
    z = 0;
    for(i=strlen(sum)-1,j=strlen(a)-1;i>=0||j>=0;i--,j--){
        if(i >= 0)
            z+=sum[i]-'0';
        if(j >= 0)
            z+=a[j]-'0';
        c[k++] = z%10+'0';
        z = z/10;
    }
    if(z){
        c[k++] = '1';
    }
	
    c[k] = '';
    i = 0;
	count = k;
//	count = 0;
    for(--k;k>=0;k--){
        sum[i++] = c[k];
//		count++;
    }
    sum[i] = '';
	if(mark == 0){
		for(i=0;i<count;i++){
			if(i != count-1){
				printf("%c",sum[i]);
			}
			else{
				printf("%cn",sum[i]);
			}
		}
	}
}

int main(){
    int T,i,cas;
	//int mark;

    while(~scanf("%d",&T)){
        for(cas=1;cas<=T;cas++){
			mark = 1;
            memset(a,sizeof(a));
            memset(b,sizeof(b));
            memset(c,sizeof(c));
            memset(sum,sizeof(sum));
			if(cas > 1){
				printf("n");
			}
            while(mark != 0){
				scanf("%s",a);
				if(strcmp(a,"0") == 0){
					mark = 0;
					jia(sum,a);
				}
				else{
					jia(sum,a);
				}
			}
		
		}
    }

    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读