加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ 题目1297Children’s Queue(递推,大数)

发布时间:2020-12-14 03:03:01 所属栏目:大数据 来源:网络整理
导读:?? Children’s Queue Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10644????Accepted Submission(s): 3431 Problem Description There are many students in PHT School. One day,the head
??

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10644????Accepted Submission(s): 3431


Problem Description
There are many students in PHT School. One day,the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words,either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF,FFFM,MFFF,FFMM,MFFM,MMFF,MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
?

Input
There are multiple cases in this problem and ended by the EOF. In each case,there is only one integer n means the number of children (1<=n<=1000)
?

Output
For each test case,there is only one integer means the number of queue satisfied the headmaster’s needs.
?

Sample Input
  
  
1 2 3
?

Sample Output
  
  
1 2 4
?

Author
SmallBeer (CML)
?

Source
杭电ACM集训队训练赛(VIII)
?

Recommend
lcy???|???We have carefully selected several similar problems for you:?? 1480? 1438? 2501? 1143? 1267?
?

递推公式;a[i]=a[i-1]+a[i-2]+a[i-4];

ac代码

#include<stdio.h>
#include<string.h>
char a[1010][1010];
char *add(char a[],char b[],char tc[])
{
	int c[10000];
	int i,j,len1,len2,k=0,max;
	memset(c,sizeof(c));
	len1=strlen(a);
	len2=strlen(b);
	i=len1-1;
	j=len2-1;
	memset(c,sizeof(c));
	while(i>=0||j>=0)
	{
		if(i>=0&&j<0)
			c[k]+=a[i]-'0';
		else
			if(i<0&&j>=0)
				c[k]+=b[j]-'0';
			else
				c[k]+=b[j]-'0'+a[i]-'0';
			k++;
			c[k]=c[k-1]/10;
			c[k-1]%=10;
			i--;
			j--;
			if(c[k])
				max=k;
			else
				max=k-1;
	}
	j=0;
	for(i=max;i>=0;i--)
	{
		tc[j++]=c[i]+'0';
	}
	tc[j]='';
	return tc;
}
void fun()
{
	int i;
	//memset(a,sizeof(a));
	strcpy(a[0],"1");
	strcpy(a[1],"1");
	strcpy(a[2],"2");
	strcpy(a[3],"4");
	for(i=4;i<1010;i++)
	{
		add(a[i-1],a[i-2],a[i]);
		add(a[i-4],a[i],a[i]);
	}
}
int main()
{
	int n;
	fun();
	while(scanf("%d",&n)!=EOF)
	{
		printf("%sn",a[n]);
	}
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读