加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 4762 Cut the Cake

发布时间:2020-12-14 03:02:29 所属栏目:大数据 来源:网络整理
导读:Cut the Cake Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 889????Accepted Submission(s): 436 Problem Description MMM got a big big big cake,and invited all her M friends to eat th

Cut the Cake

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 889????Accepted Submission(s): 436



Problem Description
MMM got a big big big cake,and invited all her M friends to eat the cake together. Surprisingly one of her friends HZ took some (N) strawberries which MMM likes very much to decorate the cake (of course they also eat strawberries,not just for decoration). HZ is in charge of the decoration,and he thinks that it's not a big deal that he put the strawberries on the cake randomly one by one. After that,MMM would cut the cake into M pieces of sector with equal size and shape (the last one came to the party will have no cake to eat),and choose one piece first. MMM wants to know the probability that she can get all N strawberries,can you help her? As the cake is so big,all strawberries on it could be treat as points.
?

Input
First line is the integer T,which means there are T cases.
For each case,two integers M,N indicate the number of her friends and the number of strawberry.
(2 < M,N <= 20,T <= 400)
?

Output
As the probability could be very small,you should output the probability in the form of a fraction in lowest terms. For each case,output the probability in a single line. Please see the sample for more details.
?

Sample Input
  
  
2 3 3 3 4
?

Sample Output
  
  
1/3 4/27
?

Source
2013 ACM/ICPC Asia Regional Changchun Online


题目链接 :http://acm.hdu.edu.cn/showproblem.php?pid=4762

题目大意 :M个人分蛋糕,N个草莓随机分布在蛋糕上,把蛋糕平均分并优先选择一块,求你能拿到所有草莓的概率。

题目分析 :取最外面的一个草莓为第一刀切的位置,这样一共有N种方案,然后剩下N-1个草莓,每个的概率为1/M.所以概率为N / M ^ (N - 1)要求化简输出。

代码:
import java.util.Scanner;
import java.math.*;
public class Main
{
    static Scanner in = new Scanner(System.in);
    public static void main(String args[])
    {
        int ca;
        BigInteger n,m,tmp;
        ca = in.nextInt();
        while(ca-- != 0)
        {
            m = in.nextBigInteger();
            n = in.nextBigInteger();
            m = m.pow(n.intValue() - 1);
            tmp = m.gcd(n);
            System.out.println(n.divide(tmp) + "/" + m.divide(tmp));
        }
    }
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读