加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Persistent Numbers(大数+发现java注意点!!!)

发布时间:2020-12-14 03:00:51 所属栏目:大数据 来源:网络整理
导读:Link:点击打开链接 Problem: Persistent Numbers Time Limit: ?1000MS ? Memory Limit: ?65536K Total Submissions: ?3029 ? Accepted: ?1470 Description The multiplicative persistence of a number is defined by Neil Sloane (Neil J.A. Sloane in Th

Link:点击打开链接

Problem:

Persistent Numbers
Time Limit:?1000MS ? Memory Limit:?65536K
Total Submissions:?3029 ? Accepted:?1470

Description

The multiplicative persistence of a number is defined by Neil Sloane (Neil J.A. Sloane in The Persistence of a Number published in Journal of Recreational Mathematics 6,1973,pp. 97-98.,1973) as the number of steps to reach a one-digit number when repeatedly multiplying the digits. Example:?
679 -> 378 -> 168 -> 48 -> 32 -> 6.

That is,the persistence of 679 is 6. The persistence of a single digit number is 0. At the time of this writing it is known that there are numbers with the persistence of 11. It is not known whether there are numbers with the persistence of 12 but it is known that if they exists then the smallest of them would have more than 3000 digits.?
The problem that you are to solve here is: what is the smallest number such that the first step of computing its persistence results in the given number?

Input

For each test case there is a single line of input containing a decimal number with up to 1000 digits. A line containing -1 follows the last test case.

Output

For each test case you are to output one line containing one integer number satisfying the condition stated above or a statement saying that there is no such number in the format shown below.

Sample Input

0
1
4
7
18
49
51
768
-1

Sample Output

10
11
14
17
29
77
There is no such number.
2688

Source

Waterloo local 2003.07.05

错误代码:

import java.util.*;

import java.io.*;
import java.math.*;
import java.text.*;


public class Main{
public static void main(String[] args)
{
BigInteger x;
int i;
? ? ? ? String s;
Scanner cin=new Scanner(System.in);
while(cin.hasNext())
{
x=cin.nextBigInteger();
if(x.compareTo(BigInteger.valueOf(-1))==0)
break;
if(x.compareTo(BigInteger.valueOf(10))<0)
{
System.out.println("1"+x);
}
else
{
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? s="";
for(i=9;i>=2;i--)
{
while(x.mod(BigInteger.valueOf(i))==BigInteger.valueOf(0))//这样写poj是wa!!!
{
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? s=i+s;
x=x.divide(BigInteger.valueOf(i));
}
}
if(x.compareTo(BigInteger.ONE)!=0)
{
System.out.println("There is no such number.");
}
else
{
System.out.println(s);
}
}
}
}

}


发现后改正AC代码:

import java.util.*;
import java.io.*;
import java.math.*;
import java.text.*;


public class Main{
public static void main(String[] args)
{
BigInteger x;
int i;
? ? ? ? String s;
Scanner cin=new Scanner(System.in);
while(cin.hasNext())
{
x=cin.nextBigInteger();
if(x.compareTo(BigInteger.valueOf(-1))==0)
break;
if(x.compareTo(BigInteger.valueOf(10))<0)
{
System.out.println("1"+x);
}
else
{
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? s="";
for(i=9;i>=2;i--)
{
while(x.mod(BigInteger.valueOf(i)).compareTo(BigInteger.valueOf(0))==0)//就改了这一句就AC了!!! { ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? s=i+s; x=x.divide(BigInteger.valueOf(i)); } } if(x.compareTo(BigInteger.ONE)!=0) { System.out.println("There is no such number."); } else { System.out.println(s); } } } } }

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读