加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDoj-1042 大数阶乘

发布时间:2020-12-14 02:59:48 所属栏目:大数据 来源:网络整理
导读:N! Time Limit: 10000/5000 MS (Java/Others)??? Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 53785??? Accepted Submission(s): 15217 Problem Description Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N! Input

N!
Time Limit: 10000/5000 MS (Java/Others)??? Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53785??? Accepted Submission(s): 15217

Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!


Input
One N in one line,process to the end of file.


Output
For each N,output N! in one line.

?
Sample Input
1
2
3
?

Sample Output
1
2
6

#include<stdio.h> 
#include<string.h>
const int maxn=50000;    //数组开到50000就可以满足10000的阶乘不越界 
int fun[maxn];
int main()
{
	int i,j,n;
	while(~scanf("%d",&n))
	{
 
	   memset(fun,sizeof(fun));
	   fun[0]=1;
	   for(i=2;i<=n;i++)          //从2的阶乘开始,一直到指定数的阶乘 
	   {
		   int c=0;
	    	for(j=0;j<maxn;j++)  //将所得阶乘数放在fun数组中,低位放在fun[0]中 
	    	{
			    int s=fun[j]*i+c;
		      	fun[j] =s%10;
		      	c=s/10;
	        }
       }
       
	  for(j=maxn-1;j>=0;j--)     //找出该数的最高位,即数组角码最大且不为0的数  
	           if(fun[j])  break;
	  for(i=j;i>=0;i--)  
	          printf("%d",fun[i]);
 	  printf("n");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读