加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdoj 1865 1sting 【大数】【斐波那契】

发布时间:2020-12-14 02:59:45 所属栏目:大数据 来源:网络整理
导读:1sting Time Limit: 5000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3411????Accepted Submission(s): 1318 Problem Description You will be given a string which only contains ‘1’; You can merge tw

1sting

Time Limit: 5000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3411????Accepted Submission(s): 1318


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’,or leave the ‘1’ there. Surly,you may get many different results. For example,given 1111,you can get 1111,121,112,211,22. Now,your work is to find the total number of result you can get.
?

Input
The first line is a number n refers to the number of test cases. Then n lines follows,each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
?

Output
The output contain n lines,each line output the number of result you can get .
?

Sample Input
  
  
3 1 11 22222
?

Sample Output
  
  
1 2 8
?

Author
z.jt


#include <stdio.h>
#include <string.h>
int s[205][200] = {0};
void table(){
    s[1][0] = 1; s[2][0] = 2;
    int i,j;
    for(i = 3; i < 205; ++ i){
        for(j = 0; j < 200; ++ j){
            s[i][j] = s[i-1][j]+s[i-2][j];
        }
        for(j = 0; j < 199; ++ j){
            if(s[i][j] > 9){
                s[i][j] -= 10;
                s[i][j+1]+=1;
            }
        }
    }
}
int main(){
    int t;
    table();
    char w[205];
    scanf("%d",&t);
    while(t --){
        scanf("%s",w);
        int len = strlen(w);
        int i = 199;
        while(i>0&&!s[len][i]) i--;
        for(; i > 0; i --) printf("%d",s[len][i]);
        printf("%dn",s[len][0]);
    }
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读