加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU1013_Digital Roots【大数】【水题】

发布时间:2020-12-14 02:59:41 所属栏目:大数据 来源:网络整理
导读:Digital Roots Time Limit: 2000/1000 MS (Java/Others) ? ?Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 49834 ? ?Accepted Submission(s): 15544 Problem Description The digital root of a positive integer is found by summing th
Digital Roots


Time Limit: 2000/1000 MS (Java/Others) ? ?Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49834 ? ?Accepted Submission(s): 15544




Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits,those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.


For example,consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit,6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit,the process must be repeated. Adding the 1 and the 2 yeilds 3,a single digit and also the digital root of 39.
?


Input
The input file will contain a list of positive integers,one per line. The end of the input will be indicated by an integer value of zero.
?


Output
For each integer in the input,output its digital root on a separate line of the output.
?


Sample Input
24
39
0
?


Sample Output
6
3
?


Source
Greater New York 2000
?


Recommend

We have carefully selected several similar problems for you: ?1017 1021 1048 1016 1019?

题目大意:给你一个数,若这个数的各个位数上的和为一位数字,则输出结果。否则继续计算上一结果

的各个位数上的和,知道结果为一位数字,进行输出

思路:本以为九余数定理直接水过,发现64位数也不行~果断大数A过

#include<stdio.h>
#include<string.h>
char num[110];
int main()
{
    while(~scanf("%s",num) && num[0]!='0')
    {
        int len = strlen(num);
        int sum = 0;
        for(int i = 0; i < len; i++)
        {
            sum += num[i] - '0';
        }

        while(sum > 9)
        {
            int a = 0;
            while(sum > 0)
            {
                a += sum % 10;
                sum /= 10;
            }
            if(a != 0)
                sum = a;
        }

        printf("%dn",sum);
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读