加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

杭电1250 Hat's Fibonacci(大数+1000进制输出)

发布时间:2020-12-14 02:58:57 所属栏目:大数据 来源:网络整理
导读:Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7853????Accepted Submission(s): 2550 Problem Description A Fibonacci sequence is calculated by adding the previous two

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7853????Accepted Submission(s): 2550


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
?

Input
Each line will contain an integers. Process to end of file.
?

Output
For each case,output the result in a line.
?

Sample Input
  
  
100
?

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
/*
这道题的收获之处主要是会处理大数的10000进制,以后遇到情况可以处理,加油!!
Time:2014-10-20 8:07
*/
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define MAX 10000+10
#define MM 300
#define SYS 10000000
int dig[MAX]={0,0};
int f[MAX][300];
void Get_f(){
	memset(f,sizeof(f));
	f[1][0]=1;f[2][0]=1;f[3][0]=1;f[4][0]=1;
	for(int i=5;i<MAX;i++){
		int t=0;
		for(int j=0;j<MM;j++){
			f[i][j]+=(t+f[i-1][j]+f[i-2][j]+f[i-3][j]+f[i-4][j]);
			t=f[i][j]/SYS;
			f[i][j]%=SYS;
		}
	}
}
int main(){
	int n,i;
	 Get_f();
	while(scanf("%d",&n)!=EOF){
		i=MM-1;
		while(f[n][i]==0)i--;
		printf("%d",f[n][i--]);//输出后-- 
		for(;i>=0;i--)
		printf("%07d",f[n][i]);
		puts("");
	}
return 0;
} 

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读