加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu1250Hat's Fibonacci(大数加法)

发布时间:2020-12-14 02:56:13 所属栏目:大数据 来源:网络整理
导读:Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7938????Accepted Submission(s): 2585 Problem Description A Fibonacci sequence is calculated by adding the previous two

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7938????Accepted Submission(s): 2585


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
?

Input
Each line will contain an integers. Process to end of file.
?

Output
For each case,output the result in a line.
?

Sample Input
  
  
100
?

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
#include<stdio.h>
#include<string.h>
#define MAX 3000+3
char str1[MAX],str2[MAX],c[MAX];
void change(char str1[],char str2[],char sum[])
{
	int len1,len2,i,j,k,z;
	len1=strlen(str1)-1;
	len2=strlen(str2)-1;
	z=0;
	k=0;
	for(i=len1,j=len2;i>=0||j>=0;i--,j--)
	{
		if(i>=0)
			z+=str1[i]-'0';
		if(j>=0)
			z+=str2[j]-'0';
		c[k++]=z%10+'0';
		z=z/10;
	}
	if(z) c[k++]='1';
	i=0;
	for(--k;k>=0;k--)
	sum[i++]=c[k];
	sum[i]='';
}
int main()
{
	int n,i;
	while(scanf("%d",&n)!=EOF)
	{
		char str1[MAX]="1",str2[MAX]="1",str3[MAX]="1",str4[MAX]="1";//相当于题目中的f(1)=1,f(2)=1,f(3)=1,f(4)=1; 
		char f[MAX],f1[MAX],sum1[MAX];
		if(n==0)
		{
			printf("0n");
			continue;
		}
		for(i=4;i<n;i++)
		{
			change(str1,str2,f);
			change(str3,str4,f1);
			change(f,f1,sum1);
			strcpy(str1,str2);
			strcpy(str2,str3);
			strcpy(str3,str4);
			strcpy(str4,sum1);
		}
		printf("%sn",str4);
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读