A+B Problem II
时间限制:
3000?ms ?|? 内存限制:
65535?KB
难度:
3
-
描述
-
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
A,B must be positive.
-
输入
-
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
-
输出
-
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation.
-
样例输入
-
2
1 2
112233445566778899 998877665544332211
-
样例输出
-
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110
??开始落下了输出格式,赤裸裸的wa。。哈哈
?输入的时候是两个字符串,所以就又开辟了数组,和大数阶乘一样,也是数的个位放在数组num[0]上,注意进位。
代码:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAX 2000
void ADD(char str1[],char str2[])
{
int len1 = strlen(str1);
int len2 = strlen(str2);
//printf("%d %d",len1,len2);
int num1[MAX];
int num2[MAX];
memset(num1,sizeof(num1));
memset(num2,sizeof(num2)); //注意清0
int i,j;
for(i=len1-1,j=0; i>=0; i--)
{
num1[j++] = str1[i] - '0'; //注意字符转换成数字的时候要减去‘0’
}
for(i=len2-1,j=0; i>=0; i--)
{
num2[j++] = str2[i] - '0';
}
for(i=0; i<MAX; i++)
{
num1[i] += num2[i]; //开始从个位相加,也就是数组的0开始
if(num1[i] > 9) //判断是否产生进位,进位就数组的下一个元素+1
{
num1[i] -= 10;
num1[i+1] ++;
}
}
for(i=MAX-1; i>=0; i--) //判断第一个不为0的地方,从这里开始输出数组元素,也就是最后的和
{
if(num1[i] != 0)
break;
}
printf("%s + %s = ",str1,str2); //注意输出的结构!!!
for(j=i; j>=0; j--)
{
printf("%d",num1[j]);
}
printf("n");
}
int main()
{
int n;
scanf("%d",&n);
getchar();
int i;
for(i=1; i<=n; i++)
{
char str1[MAX];
char str2[MAX];
scanf("%s%s",str2);
printf("Case %d:n",i); //注意输出的结构!
ADD(str1,str2);
}
return 0;
}
最优代码
import java.math.BigInteger;
import java.util.Scanner;
public class Main{
public static void main(String args[]) {
Scanner cin=new Scanner(System.in);
int n=cin.nextInt();
BigInteger a,b;
for(int i=1;i<=n;i++){
a=cin.nextBigInteger();
b=cin.nextBigInteger();
System.out.println("Case "+i+":");
System.out.println(a.toString()+" + "+b.toString()+" = "+a.add(b));
}
}
}
额....java 的代码,表示目前还看不懂啊~~
(编辑:李大同)
【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!
|