加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

UVA 10494-If We Were a Child Again(大数除法及取余)

发布时间:2020-12-14 02:53:27 所属栏目:大数据 来源:网络整理
导读:If We Were a Child Again Time Limit: 3000 MS????? Memory Limit: 0 KB????? 64bit IO Format: %lld %llu Submit? Status Description Problem C If We Were a Child Again Input: ?standard input Output: ?standard output Time Limit:? 7 ?seconds ? “

If We Were a Child Again
Time Limit:3000MS?????Memory Limit:0KB?????64bit IO Format:%lld & %llu
Submit? Status

Description

Problem C
If We Were a Child Again

Input:?standard input
Output:?standard output

Time Limit:?7?seconds

?

“Oooooooooooooooh!

If I could do the easy mathematics like my school days!!

I can guarantee,that I’d not make any mistake this time!!”

Says a smart university student!!

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

?

?

The Problem

?

The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

?

But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him,he asks you to write the program. But,you are also intelligent enough to tackle this kind of people.?You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

?

Input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number?n?will be in the range (0 < n < 231).

?

?
Output

A line for each input,each containing an integer. See the sample input and output. Output should not contain any extra space.

?

?
?
Sample Input

110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

?

?

?

?

?
?
Sample Output

1

9

1

2147483646

?



#include <stdio.h>
#include <string.h>
#include <stdlib.h>
char a[10010];
long long b[10010];
int main()
{
    int n,i;
    long long cnt,num,div;
    char c;
    int flag;
    while(~scanf("%s %c %d",a,&c,&n))
    {

        cnt=0;
        num=0;
        flag=0;
        int len=strlen(a);
        for(i=0;i<len;i++)
        {
            num=num*10+a[i]-'0';
            div=num/n;
            if(div!=0||(div==0&&flag==1))
            {
                b[cnt++]=div;
                flag=1;
            }
            num%=n;
        }
        if(c=='/')
        {
            if(cnt==0)
                printf("0");
            else
                for(i=0;i<cnt;i++)
                printf("%lld",b[i]);
        }
        else
        {
            printf("%lld",num);
        }
        printf("n");
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读