加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1047。多个大数相加

发布时间:2020-12-14 02:51:13 所属栏目:大数据 来源:网络整理
导读:Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13496????Accepted Submission(s): 3390 Problem Description One of the first users of BIT's new supercomputer was Chip D

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13496????Accepted Submission(s): 3390


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)
?

Input
The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
?

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
?

Sample Input
  
  
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
?

Sample Output
  
  
370370367037037036703703703670
?

Source
East Central North America 1996

?

题意,就是多个大数相加,以0为结束输入的标志,然后输出。坑点:(直接输入0时要输出0(因为这个WA了一次。),最后一个案例不需要输出两个空行。)

只要把两个大数的相加的会了,这个其实只是照搬。

贴个代码

?

#include <stdio.h>
#include <string.h>
#define N 205
int main()
{
	int n,lena,l,i,j,flag;
	char a[N];//字符数组
	int a1[N]={0};//  这个数组用来存最终的值
    int a2[N];  //   这个数组用来存输入的值,下面不断的更新它,然后加到a1[N]这个数组上。
    scanf("%d",&n);
	while(n--)
	{
		flag=0;//用flag控制格式
		while(scanf("%s",a)!=EOF)
		{
			flag++;
			if(a[0]=='0')
			{
				break;
			}
			memset(a2,sizeof(a2));  //每次都初始化它
			lena=strlen(a);
			for(i=lena-1,l=0;i>=0;i--)//直接存入
				a2[l++]=a[i]-'0';
			for(i=0;i<N;i++)
			{
				a1[i]+=a2[i];  //加到a1的数组上去。
				if(a1[i]>=10)  //进位
				{
					a1[i]-=10;
					a1[i+1]++;
				}
			}
		}
		if(flag==1)  //如果flag为一说明输入就一个0,此时输出0。
		{
			printf("0n");
		}
		else
		{
			for(i=N-1;i>=0;i--)
				if(a1[i])
					break;
				for(j=i;j>=0;j--)
					printf("%d",a1[j]);//输出a1数组。
				printf("n");
		}
		if(n!=0)
			printf("n");//格式控制。
		memset(a1,sizeof(a1));//一个案例结束后初始化a1数组。
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读