加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

POJ 2506-Tiling(递推+大数)

发布时间:2020-12-14 02:50:50 所属栏目:大数据 来源:网络整理
导读:Tiling Time Limit: ?1000MS ? Memory Limit: ?65536K Total Submissions: ?7897 ? Accepted: ?3841 Description In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?? Here is a sample tiling of a 2x17 rectangle.? Input Input is a se

Tiling
Time Limit:?1000MS ? Memory Limit:?65536K
Total Submissions:?7897 ? Accepted:?3841

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles??
Here is a sample tiling of a 2x17 rectangle.?


Input

Input is a sequence of lines,each line containing an integer number 0 <= n <= 250.

Output

For each line of input,output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.?

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251
50
ps:本以为要用求大数的方法写个函数,然后调用它,那也太麻烦了,然后飞神告诉了我这个方法,太神奇了,总共才250,250*110果断爆不了。用二维数组存储大数的每一位。感觉我还是太年轻 sad~

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
char a[310][120];
int main()
{
        int n,i,j;
        memset(a,'0',sizeof(a));
        a[0][0]='1';
        a[1][0]='1';
        a[2][0]='3';
        for(i=3; i<=250; i++)
        {
                for(j=0; j<110; j++)
                {
                        int sum=2*(a[i-2][j]-'0')+a[i-1][j]-'0'+a[i][j]-'0';
                        a[i][j]=sum%10+'0';
                        a[i][j+1]=sum/10+'0';
                }
        }
        while(~scanf("%d",&n))
        {
                int flag=0;
                for(i=110; i>=0; i--)
                        if(a[n][i]!='0')
                        {
                                flag=i;
                                break;
                        }
                for(i=flag; i>=0; i--)
                        printf("%c",a[n][i]);
                printf("n");
        }
        return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读