加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

NYOJ A+B Problem II(大数A+B)

发布时间:2020-12-14 02:50:32 所属栏目:大数据 来源:网络整理
导读:A+B Problem II 时间限制: 3000 ?ms ?|? 内存限制: 65535 ?KB 难度: 3 描述 I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B. A,B must be positive. 输入 The first line of the input co

A+B Problem II

时间限制: 3000?ms ?|? 内存限制: 65535?KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110


解题方法:

? ? ? ? ? ? ?先将字符串反转存入整形数组,整形数组按位相加,若相加后大于十则前一位加一。相加结束后,

? ? ?倒叙逐个输出整形数组的每一位数。

代码如下:


#include<stdio.h>
#include<string.h>
#include<stdlib.h>

int max(int x,int y)
{
	int z;
	z=x>y ? x:y;
	return z;//比较两个数的大小,将较大的数赋值给返回值 
}

int  main()
{
	int i,n,t=0,z,lena,lenb,num1[1100],num2[1100];
	char a[1100],b[1100];
	scanf("%d",&n);
	while(n--)
	{
		memset(num1,sizeof(num1));
		memset(num2,sizeof(num2));//int型数组清零 
		scanf("%s%s",&a,&b);
		lena=strlen(a);
		lenb=strlen(b);
		for(i=0;i<lena;i++)
		  num1[lena-1-i]=a[i]-'0';
		for(i=0;i<lenb;i++)
		  num2[lenb-1-i]=b[i]-'0';
		z=max(lena,lenb);
		for(i=0;i<z;i++)//此处i值的范围就是两个字符串长度的最大者 
		{
			num1[i]=num1[i]+num2[i];
			if(num1[i]>9)//处理相加大于十的情况 
			{
				num1[i]=num1[i]-10;
				num1[i+1]++; 
			}
		}
		t++;
		if(num1[z]==0)// 判断数组第z位是否为零 
		{
			printf("Case %d:n",t);
			printf("%s + %s = ",a,b);
			for(i=z-1;i>=0;i--)
			  printf("%d",num1[i]);
			printf("n");
		}
		else 
		{
			printf("Case %d:n",b);
			for(i=z;i>=0;i--)
			  printf("%d",num1[i]);
			printf("n");
		}
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读