加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU-多个大数加法问题

发布时间:2020-12-14 02:48:45 所属栏目:大数据 来源:网络整理
导读:问题及代码: /* *Copyright (c)2014,烟台大学计算机与控制工程学院 *All rights reserved. *文件名称:HDU.cpp *作 者:单昕昕 *完成日期:2015年1月27日 *版 本 号:v1.0 *问题描述:One of the first users of BIT's new supercomputer was Chip Diller.
问题及代码:
/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月27日  
*版 本 号:v1.0  
*问题描述:One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
*程序输入:The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself.
*程序输出:Your program should output the sum of the VeryLongIntegers given in the input. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input
1


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670
*/
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
? ? char str[100];
? ? int x,c,n,i,j,sum[110];
? ? cin>>n;
? ? while(n--)
? ? {
? ? ? ? memset(sum,sizeof(sum));
? ? ? ? c=0;
? ? ? ? while(cin>>str,strcmp(str,"0"))
? ? ? ? {
? ? ? ? ? ? for(i=j=strlen(str)-1; 0<=i; i--)
? ? ? ? ? ? ? ? sum[j-i]+=str[i]-'0';
? ? ? ? }
? ? ? ? for(i=0; i<110; i++)
? ? ? ? {
? ? ? ? ? ? x=sum[i]+c;
? ? ? ? ? ? sum[i]=x%10;
? ? ? ? ? ? c=x/10;
? ? ? ? }
? ? ? ? i=109;
? ? ? ? while(sum[i]==0)i--;
? ? ? ? if(i<0)cout<<"0";
? ? ? ? for(; i>=0; i--)
? ? ? ? ? ? cout<<sum[i];
? ? ? ? cout<<endl;
? ? ? ? if(n)cout<<endl;
? ? }
? ? return 0;
}



运行结果:



知识点总结:
多个大数加法问题。

学习心得:

跟小数加法差不多。。

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读