加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

(hdu step 2.3.1)A + B Problem II(大数加法)

发布时间:2020-12-14 02:47:48 所属栏目:大数据 来源:网络整理
导读:题目: ? ? ? ?? A + B Problem II Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2372 Accepted Submission(s): 917 ? Problem Description I have a very simple problem for you. Given two i

题目:

? ? ? ??

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2372 Accepted Submission(s): 917
?
Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?
Output

????????????For each test case,you should output two lines. The first line is \"Case #:\",# means the number of the test case. The second line is the an equation \"A + B = Sum\",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?
Sample Input
2
1 2
112233445566778899 998877665544332211
?
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110
?
Author
Ignatius.L
?


题目分析:

? ? ? ? ? ? ? ? 简单题。这种题比赛的时候直接用java写就好,用C/C++来做其实也是那么个意思。java的BigInteger的相关类底层就是那么实现的。所以没必要写那么1、200,行代码。无论是开发也好,还是算法也好,个人觉得都应该选择最合适的方法来解决问题,而不要拘泥于某种技术。当然,C/C++关于大数的思想还是得看一下的,对于初学者来说,理解后自己敲一遍也是有必要的。但是过了初学阶段的话,个人觉得直接用java来做就好了。



代码如下:

import java.math.BigInteger;
import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		
		int n = scanner.nextInt();
		int i;
		for(i = 1 ; i <= n ; ++i){
			System.out.println("Case "+ i +":");
			
			BigInteger a = scanner.nextBigInteger();
			BigInteger b = scanner.nextBigInteger();
			
			System.out.println(a+" + " + b + " = " + a.add(b));
			if(i != n){//最后一个不要出现空行,否则会PE
				System.out.println();
			}
		}
	}
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读