加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU-大数取模-最多100000位

发布时间:2020-12-14 02:47:45 所属栏目:大数据 来源:网络整理
导读:问题及代码: /* *Copyright (c)2014,烟台大学计算机与控制工程学院 *All rights reserved. *文件名称:mod.cpp *作 者:单昕昕 *完成日期:2015年2月3日 *版 本 号:v1.0 * *问题描述:As we know,Big Number is always troublesome. But it's really impor
问题及代码:

/* 
*Copyright (c)2014,烟台大学计算机与控制工程学院 
*All rights reserved. 
*文件名称:mod.cpp 
*作    者:单昕昕 
*完成日期:2015年2月3日 
*版 本 号:v1.0 
* 
*问题描述:As we know,Big Number is always troublesome. But it's really important in our ACM. And today,your task is to write a program to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.
*程序输入:The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.
*程序输出:For each test case,you have to ouput the result of A mod B.
Sample Input
2 3
12 7
152455856554521 3250
Sample Output
2
5
1521
*/
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
	char str[100000];
	int s,len,sum,i;
	while(cin>>str>>s)
	{
		len=strlen(str);
		sum=0;
		for(i=0;i<len;i++)
		sum=(sum*10+(str[i]-'0')%s)%s;
		cout<<sum<<endl;
	}
	return 0;
}


运行结果:


知识点总结:

大数取模。

我一开始想会不会有下面这些的结论,后来一百度发现还真有。

对于大数问题,从来都只能巧胜~~~

A*B % C = (A%C * B%C)%C
(A+B)%C = (A%C + B%C)%C
如 532 mod 7 =(500%7+30%7+2%7)%7;
当然还有a*b mod c=(a mod c+b mod c)mod c;
如35 mod 3=((5%3)*(7%3))%3

学习心得:

大数问题真是硬伤,上周的题目被虐的死去活来的。。

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读