加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU-A Fibonacci sequence斐波那契数列-大数求和

发布时间:2020-12-14 02:47:44 所属栏目:大数据 来源:网络整理
导读:问题及代码: /* *Copyright (c)2014,烟台大学计算机与控制工程学院 *All rights reserved. *文件名称:Fibonacci.cpp *作 者:单昕昕 *完成日期:2015年2月3日 *版 本 号:v1.0 * *问题描述:A Fibonacci sequence is calculated by adding the previous tw
问题及代码:
/* 
*Copyright (c)2014,烟台大学计算机与控制工程学院 
*All rights reserved. 
*文件名称:Fibonacci.cpp 
*作    者:单昕昕 
*完成日期:2015年2月3日 
*版 本 号:v1.0 
* 
*问题描述:A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
*程序输入:Each line will contain an integers. Process to end of file.
*程序输出:For each case,output the result in a line.
Sample Input
100
Sample Output
4203968145672990846840663646


Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
*/
#include<stdio.h>
int n,i,j,ans[8000][255]= {{0}};
int main()
{
    for(i=1; i<5; i++)ans[i][1]=1;
    for(i=5; i<8000; i++)
        for(j=1; j<255; j++)
        {
            ans[i][j]+=ans[i-1][j]+ans[i-2][j]+ans[i-3][j]+ans[i-4][j];
            ans[i][j+1]+=ans[i][j]/100000000;
            ans[i][j]=ans[i][j]%100000000;

        }
    while(scanf("%d",&n)!=EOF)
    {
        for(i=254; i>0; i--)
            if(ans[n][i])break;
        printf("%d",ans[n][i]);
        for(--i; i>0; i--)
            printf("%.8d",ans[n][i]);
        printf("n");
    }
    return 0;
}



运行结果:


知识点总结:
斐波那契数列-大数求和。

学习心得:

又是大数求和,套了个斐波那契数列的帽子。。

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读