加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

Bi-shoe and Phi-shoe(欧拉函数)

发布时间:2020-12-14 02:45:46 所属栏目:大数据 来源:网络整理
导读:A -? Bi-shoe and Phi-shoe Time Limit: 2000 MS????? Memory Limit: 32768 KB????? 64bit IO Format: %lld %llu Submit? Status Description Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach fo

A -?Bi-shoe and Phi-shoe
Time Limit:2000MS?????Memory Limit:32768KB?????64bit IO Format:%lld & %llu
Submit? Status

Description

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students,so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo =?Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information,?Φ (n)?= numbers less than?n?which are relatively prime (having no common divisor other than 1) to?n. So,score of a bamboo of length 9 is 6 as 1,2,4,5,7,8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist,each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer?T (≤ 100),denoting the number of test cases.

Each case starts with a line containing an integer?n (1 ≤ n ≤ 10000)?denoting the number of students of Phi-shoe. The next line contains?n?space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range?[1,106].

Output

For each case,print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha


题目链接:http://www.bnuoj.com/bnuoj/problem_show.php?pid=13288


被这个题目最后的输出格式气得半天,__int64输出用lld输出才AC,用I64d不行。

欧拉函数定义:比他小的并与他互质的个数之和。

题意给你n个luky数字是欧拉函数的值。也就是个数,求和最小,我就想应该是比这个数大的质数就肯定是最小的,这样先把所有质数枚举出来就好办了。用到了素数筛选法。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>
#include <ctime>
#define LL __int64
#define eps 1e-8
#define pi acos(-1)
using namespace std;
int a[1010010];
int p[100000];
void INIT(){
	memset(a,sizeof(a));
	memset(p,sizeof(p));
	int t=0;
	for (int i=2;i<=1010000;i++){
		if (a[i]==0)
			p[++t]=i;
		for (int j=1,k;j<=t && ((k=i*p[j])<=1010000);j++)
		{
			a[k]=1;
			if (i % p[j]==0) break; 
		} 
	}
	t=1;
	for (int i=1;i<=1000001;i++){
		if (i<p[t]) a[i]=p[t];
		else {
			t++;
			a[i]=p[t];
		}
	}
}
int main(){
	INIT();
	int T;
	//freopen("in.txt","r",stdin);
	//fropen("out.txt","w",stdout)
	scanf("%d",&T);
	for (int cas=1;cas<=T;cas++){
		int n,k;
		scanf("%d",&n);
		LL ans=0;
		for(int i=1;i<=n;i++){
			scanf("%d",&k);
			ans+=a[k];
		}
		printf("Case %d: %lld Xukhan",cas,ans);
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读