加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu-1250-Hat's Fibonacci(大数问题)

发布时间:2020-12-14 02:40:54 所属栏目:大数据 来源:网络整理
导读:Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8494????Accepted Submission(s): 2765 Problem Description A Fibonacci sequence is calculated by adding the previous two

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8494????Accepted Submission(s): 2765



Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
?

Input
Each line will contain an integers. Process to end of file.
?

Output
For each case,output the result in a line.
?

Sample Input
  
  
100
?

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
?

Author
戴帽子的
?

Recommend
Ignatius.L???|???We have carefully selected several similar problems for you:?? 2100? 1133? 1297? 1063? 1047?
?

Statistic?|? Submit?|? Discuss | Note
大数
/*
 * http://acm.hdu.edu.cn/showproblem.php?pid=1250
 * by jtahstu on 2015/3/31 14:00
 */
package 大数;

import java.math.BigInteger;
import java.util.Scanner;

public class HDU1250 {
	public static Scanner cin=new Scanner(System.in);
	public static void main(String[] args) {
		// TODO 自动生成的方法存根
		BigInteger a[]=new BigInteger[1000];
		a[1]=a[2]=a[3]=a[4]=BigInteger.valueOf(1);
		for (int i = 5; i <=999; i++) {
			a[i]=a[i-1].add(a[i-2]).add(a[i-3]).add(a[i-4]);
		}
		while (cin.hasNext()) {
			int n=cin.nextInt();
			
			System.out.println(a[n]);
		}
	}

}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读