加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu-1865-1sting(大数问题)

发布时间:2020-12-14 02:40:50 所属栏目:大数据 来源:网络整理
导读:1sting Time Limit: 5000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3870????Accepted Submission(s): 1463 Problem Description You will be given a string which only contains ‘1’; You can merge tw

1sting

Time Limit: 5000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3870????Accepted Submission(s): 1463



Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’,or leave the ‘1’ there. Surly,you may get many different results. For example,given 1111,you can get 1111,121,112,211,22. Now,your work is to find the total number of result you can get.
?

Input
The first line is a number n refers to the number of test cases. Then n lines follows,each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
?

Output
The output contain n lines,each line output the number of result you can get .
?

Sample Input
  
  
3 1 11 22222
?

Sample Output
  
  
1 2 8
?

Author
z.jt
?

Source
2008杭电集训队选拔赛——热身赛
?

Recommend

lcy???|???We have carefully selected several similar problems for you:??1133?2100?1297?1866?1868?

按字符串长度递推,然后2的n次方是个大数

/*
 * http://acm.hdu.edu.cn/showproblem.php?pid=1865
 * by jtahstu on 2015/3/31 14:00
 */
package 大数;

import java.math.BigInteger;
import java.util.Scanner;

public class HDU1865 {
	public static Scanner cin = new Scanner(System.in);

	public static void main(String[] args) {
		// TODO 自动生成的方法存根
		int n = cin.nextInt();
		BigInteger a[] = new BigInteger[201];
		a[1] = BigInteger.valueOf(1);
		a[2] = BigInteger.valueOf(2);
		for (int i = 3; i <= 200; i++)
			a[i] = a[i - 1].add(a[i - 2]);//递推,只是这是大数
		while (n-- > 0) {
			String s;
			s = cin.next();
			int len = s.length();
			System.out.println(a[len]);

		}
	}

}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读