加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU1002(大数)

发布时间:2020-12-14 02:37:19 所属栏目:大数据 来源:网络整理
导读:A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 230395????Accepted Submission(s): 44208 Problem Description I have a very simple problem for you. Given two integers

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 230395????Accepted Submission(s): 44208


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110


链接: http://acm.hdu.edu.cn/showproblem.php?pid=1002


题意:就是简单的A+B,就只要注意最后一组数据后没多余的空行就ok了,用c/c++比较麻烦,用java轻而易举就搞定了,so~,c的代码就不贴了。
import java.util.*;
 import java.math.*;
 public class Main {
     public static void main(String[] args) {
         int T;
         BigDecimal a,b,c;             //定义两个大数型变量a,b
         Scanner cin = new Scanner(System.in);    
         T = cin.nextInt();
         for (int i=1; i<=T; i++){
             a = cin.nextBigDecimal();
             b = cin.nextBigDecimal();
             //c = a.add(b);        //java的加法和c/c++的不同,四则运算都要写成这种形式
             System.out.println("Case "+i+":");
             System.out.println(a+" + "+b+" = "+(a.add(b)));
             if (i != T)        //最后一组数据后没有多余的空行。
             System.out.println();
       }

   }
 }

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读