加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ-1002大数相加

发布时间:2020-12-14 02:37:15 所属栏目:大数据 来源:网络整理
导读:参考这篇:点击打开链接 ? Problem Description I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B. ? Input The first line of the input contains an integer T(1=T=20) which means the numb

参考这篇:点击打开链接

?

Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.


?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.


?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.


?

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211


?

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110
#include <iostream>
#include<cstdio>
#include<string>
#include<string.h>
void add(char a[],char b[],char c[]);
int main(int argc,char *argv[]) {	
	int x;
	scanf("%d",&x);
	for(int i=1;i<=x;i++){	
			char a[1005],b[1005],c[1005];
			a[0]=b[0]='0';//数组首位置0,方便最高位进位 
			scanf("%s",&a[1]);
			scanf("%s",&b[1]);
			printf("Case %d:n",i);	
			add(a,b,c);
			printf("%s + %s = ",&a[1],&b[1]);
			if(c[0]!='0')printf("%c",c[0]);
			printf(i==x?"%sn":"%snn",&c[1]);
	}
	return 0;
	
}
void add(char a[],char c[]){
	int lenA,lenB,lenC;
	lenA=strlen(a);
	lenB=strlen(b);
	lenC=(lenA>lenB)?lenA:lenB;//数组c长度为a,b较长长度。 
	int carry=0,t=0;
	c[lenC]='';			//字符串以''做结束标志。 
	for(int i=lenC-1;i>=0;i--){
		lenA--;
		lenB--;
		if(lenA>=0&&lenB>=0){
			t=a[lenA]-'0'+b[lenB]-'0'+carry;carry=0;//a,b数组的末位开始相加,取其数值做判断加完进位后carry置0 
			if(t>9){
			c[i]=t-10+'0';//数值大于10 ,取其个位,进位carry置1. 
			carry=1;
			}
			else c[i]=t+'0';			
			}
			
		if(lenA>=0&&lenB<0){// a数组位数较长,将a数组多余字符赋给c。 
			t=a[lenA]-'0'+carry;carry=0;
			if(t>9){
				c[i]=t-10+'0';
				carry=1;
			}
			else c[i]=t+'0';
			}
		if(lenB>=0&&lenA<0){//b数组较长 
			t=b[lenB]-'0'+carry;carry=0;
			if(t>9){
				c[i]=t-10+'0';
				carry=1;
			}
			else c[i]=t+'0';
		}
	}	
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读