加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

*foj 1453 Bignum Arithmetic

发布时间:2020-12-14 02:36:36 所属栏目:大数据 来源:网络整理
导读:Problem Description In this problem,you will be concerned with integers with very large numbers of digits. You must write code which will repeatedly accept (until end of file) two lines each containing an unsigned integer,and output the pr

Problem Description
In this problem,you will be concerned with integers with very large numbers of digits. You must write code which will repeatedly accept (until end of file) two lines each containing an unsigned integer,and output the product of the two input unsigned integers. The output must not contain any leading zeros.

You can assume that each integer will contain at most 80 digits. The input ends with an end of file.

Sample Input
0342
1298
12
3
Sample Output
443916
36

代码:

#include<stdio.h>
#include<string.h>
char s1[1005],s2[1005];
int a[1005],b[1005],c[1500];
void mul(char s1[],char s2[])
{
    int l1,l2;
    l1=strlen(s1),l2=strlen(s2);
    int l=l1+l2;
    int i,j,k=0;
    for(i=l1-1,j=0;i>=0;i--,j++)a[j]=s1[i]-'0';
    for(i=l2-1,j++)b[j]=s2[i]-'0';
    memset(c,0,sizeof(c));//对数组c初始化
    for(i=0;i<l1;i++)
        for(j=0;j<l2;j++)
            c[i+j]+=a[i]*b[j];
    for(i=0;i<l;i++)
        if(c[i]>9)
            c[i+1]+=c[i]/10,c[i]%=10;
    while(c[l]==0&&l>0)//*去掉前导0,但保证最后有一个0!!否则结果为0不能输出
        l--;
    for(i=l;i>=0;i--)
        printf("%d",c[i]);
    printf("n");
}
int main()
{
    while(scanf("%s",s1)!=EOF)
    {
        getchar();//吞掉回车
        gets(s2);
    mul(s1,s2);
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读